I’m Told the Feed Isn’t Valid or Working

All feeds must be at least validated by using a resource like:

http://validator.w3.org/appc/

If the feed isn’t valid, it will not work in the plugin.

Also, put the feed into a Firefox browser. If nothing shows, then then feed doesn’t work. If it sometimes shows, when you refresh the browser, then the plugin will sometimes show the feed, and sometimes not.

Finally, put your feed in this demo

www.simplepie.org/demo

In short, if the feed isn’t valid or isn’t working in the demo, it simply won’t work in the plugin.  Now, note that when you do this on the simplepie site, you are using THEIR server, so it might work there, but not on your server (and your server could be the cause of this problem – see below).

If you’re using the shortcode, the next step is to check off this box in the shortcode admin tab

screenshot_914

Now, if you find that the feed is valid (using the link above) and the demo is showing your feed, and you’ve tried checking off the box above, but it doesn’t work when using the plugin, then the problem lies with your server. The reason for this is because the plugin uses simplepie (just like the demo) to read the feed in exactly the same way as the demo…but the demo is on a server that is accepting the feed. This means your server is not accepting the feed – this could be due to your WP installation or your server.

Posted in: Error Messages

  • RSS Feeds

    There is a problem - it appears you are using categories and no feeds have been put into those categories.